裏 HS Works

日常の痛いひとりごと

<< November 2019 | 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 >>

<< G5 Dual 1.8GHz PPC 強制スリープ問題 その3 | TOP | G4 に 1TB の HDD を! その1 >>

2010.10.10 Sunday

G5 Dual 1.8GHz PPC 強制スリープ問題 その4

0


    ↑ 熱伝導グリス。ダイアモンド含有率92%だって。素晴らしいらしいので購入。

    今回は巨大なヒートシンクを剥がして、CPU との接合部分のグリスを交換だい!
    下のがヒートシンクを剥がしたところ。
    赤い矢印の4カ所を六角レンチのネジで固定している。だけ?ガッチャン!とか無いんだ。まあ、楽で良いんだけど。



    でね、グリスを塗り直して組み立てて電源オン!
    あれ〜?変わんねー!
    3階塗り直してみたよ。けど温度は下がらなかった。グリスじゃないんだ...

    ■ 検証 1
    ・二つの CPU ブロックを外し、CPU A と思わしき方を上段にのみ取り付けて起動。
    → 問題なくG5 シングルで認識して起動。温度は高いまま。
    ・CPU B を、上段のみに取り付けて起動。
    → 恐ろしい勢いでファンが回り、リンゴマークで進まず。ビビって電源コードを抜く!笑
    ・CPU B を、下段のみに取り付けて起動。
    → 起動しない。電源が入らない。

    なるほどねえ、見た目同じなんだけどなあ、やっぱ違うんだね。

    CPU 温度は、専用センサーがある訳ではなく、CPU 内蔵のサーマルダイオードのに流れる電流を温度に置き換えて返しているんだって。
    つまり、CPU 温度の異常はマザボは関係ないということになる。( 全くかどうかは分かりませんが。)

    そうだ、ヤフオクで仕入れた G5 のコア、ヒートシンクを純正のにすればいいんじゃん?そうすりゃ台座の穴が違っても関係ねーし!
    オッケー、それだぜ!

    って訳で、どっちが CPU A か分かんないので2つともバラしてみたよ。
    下の写真は巨大なヒートシンクを剥がした基盤。仮に左から書いてみたけど、CPU A、B、オリジナルの A なハズ。
    しかし、この CPU の放熱にあんな巨大なヒートシンクが必要なのか?信じられんなあ...



    さて、順番にオリジナルのヒートシンクにグリスをキレイに塗布し直して合体、本体に取り付けてみよう。
    CPU A なら、シングルで起動することが確かめられたので、まずは上段のみに取り付けて起動させてみる。

    ■ 検証 2
    ・ヤフオク A を取り付けて起動。
    → 恐ろしい勢いでファンが回り、リンゴマークで進まず。ビビって電源コードを抜く!
    ・ヤフオク B を取り付けて起動。
    → 恐ろしい勢いでファンが回り、リンゴマークで進まず。ビビって電源コードを抜く!

    あれ?どっちも CPU B の振る舞いだぞ?ファンコントロールが暴走、ファームウエアとぶつかってるっぽい。

    ■ まとめてみよう。
    ・CPU A のみを上段に取り付けるとシングルとして認識、起動する。
    ・ヤフオクの CPU 基盤をオリジナルのヒートシンクに取り付けて起動してみるが、ファンが暴走して起動せず。
    ・ヤフオクのもう片方の CPU 基盤に交換してみたが同じくファンが暴走して起動せず。
    ・ヤフオクのコアは 2003 年製。オリジナルは 2004 年製。
    ・オリジナルの台座には 「え?」 【Revision B】 の刻印が〜!

    ■ 結論
    ・違うロッドの CPU は交換できないらしい。( ファームウエアに記述されてるのかなあ?)
    ・オリジナルの CPU とヒートシンクのグリスは3回塗りなおしてみたが結果は変わらなかったので、原因はグリスではなさげ。
    ・つまり、なすすべ無しです。

    これを書いてる現在は、正常だった CPU B の温度がマイナス18度とかになっちゃってるし。笑
    やっぱりお迎えが近いみたいだねえ。

    諦めて PPC G5 2GHz Dual でもヤフオクで狙うしかないのね。
    とりあえず G4 ミラー 1.25GHz Dual に環境を戻しますかー!

    まあ、ここまで試した奴いないんじゃないかなあ?
    何かのお役に立てればいいけどね!

    ■ あっ、そうだ、最初に試したことも改めて追記しておきますね。
    ・firmware は 5.1.8f2 最新
    ・本体 SMU ボタンでリセットしても改善なし。
    ・PRAM クリアーもしたが見当違いで?効果なし。
    ・iMac にある、コンセント抜いて15秒放置後、電源ボタンを押しながらコンセントを挿す。ってのも効果なし。
    ・PRAM クリアー後、Open Firmware でファームウエアをリセットしてみたが効果なし。

    以上です。

    おしまい!

    コメント

    コメントする









    この記事のトラックバックURL

    http://blog.hsw-web.com/trackback/1021995

    トラックバック

    ▲top